Check Point Advisories

DNS Client Resolver glibc Buffer Overflow (CVE-2015-7547)

Check Point Reference: CPAI-2016-0120
Date Published: 18 Feb 2016
Severity: Medium
Last Updated: 7 Nov 2017
Source:
Industry Reference:CVE-2015-7547
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable? Versions of glibc since 2.9
Vulnerability Description The Linux glibc library is vulnerable to a stack-based buffer overflow. DNS client side resolvers using this library may be exploited by remote attackers. Successful exploitation would allow an attacker to execute arbitrary code on the target.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the DNS Client Resolver glibc Buffer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  DNS Enforcement Violation.
Attack Information:  DNS Client Resolver glibc Buffer Overflow

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO