Check Point Advisories

Adobe Flash Player Remote Code Execution (APSA16-01: CVE-2016-1019)

Check Point Reference: CPAI-2016-0264
Date Published: 6 Apr 2016
Severity: Critical
Last Updated: 3 Oct 2017
Source: Adobe APSA16-01
Industry Reference:CVE-2016-1019
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable? Adobe Flash Player 21.0.0.197 and earlier versions for Windows, Macintosh, Linux, and Chrome OS.
Vulnerability Description A remote code execution vulnerability has been reported in Adobe Flash Player. The vulnerability is due to an error in Adobe Flash Player while handling a specially crafted SWF file. Successful exploitation could cause a crash and potentially allow an attacker to take control of the affected system.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the Adobe Flash Player Remote Code Execution (APSA16-01: CVE-2016-1019) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Adobe Flash Protection Violation.
Attack Information:  Adobe Flash Player Remote Code Execution (APSA16-01: CVE-2016-1019)

This website uses cookies to ensure you get the best experience. More Info Got it, Thanks!