Check Point Advisories

OpenSSL Padding Oracle Information Disclosure (CVE-2016-2107)

Check Point Reference: CPAI-2016-0349
Date Published: 9 May 2016
Severity: High
Last Updated: 6 Mar 2018
Source: OpenSSL
Industry Reference:CVE-2016-2107
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? OpenSSL 1.0.1t and 1.0.2h
Vulnerability Description An information disclosure vulnerability exists in the AES-NI implementation of OpenSSL. The vulnerability is due to memory allocation miscalculation during a certain padding check. A remote attacker can exploit this vulnerability to obtain sensitive cleartext information via a padding-oracle attack against an AES CBC session.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the OpenSSL Padding Oracle Information Disclosure protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  SSL Enforcement Violation.
Attack Information:  OpenSSL Padding Oracle Information Disclosure

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO