How can I help you? Start Chat

US Phone: 1-866-488-6691
International Phone: +44-2036087492

  • E-Mail
  • Facebook
  • LinkedIn
  • Twitter

Check Point Advisories

Cesanta Mongoose DNS Compressed Name Denial of Service (CVE-2017-2909)

Check Point Reference: CPAI-2017-1001
Date Published: 16 Nov 2017
Severity: Medium
Last Updated: 27 Nov 2017
Source: Cesanta
Industry Reference:CVE-2017-2909
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable? Cesanta Mongoose 6.8 and prior
Vulnerability Description An infinite loop vulnerability exists in the DNS server functionality of Cesanta Mongoose. The vulnerability is due to insufficient handling of compressed names in DNS queries and responses. A remote, unauthenticated attacker can exploit this vulnerability by sending a crafted DNS query or response to an application implementing the Mongoose DNS server functionality or DNS client functionality, respectively.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the Cesanta Mongoose DNS Compressed Name Denial of Service protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  DNS Enforcement Violation.
Attack Information:  Cesanta Mongoose DNS Compressed Name Denial of Service