Check Point Advisories

JbossMQ Invocation Layer Deserialization Remote Code Execution (CVE-2017-7504; CVE-2017-12149)

Check Point Reference: CPAI-2017-1066
Date Published: 13 Dec 2017
Severity: High
Last Updated: 13 Dec 2017
Source:
Industry Reference:CVE-2017-7504
CVE-2017-12149
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable? Red Hat JbossMQ prior to 4
Vulnerability Description An invocation layer deserialization vulnerability exists in Red Hat JBoss Seam Framework. A remote unauthenticated attacker may exploit this vulnerability by sending a crafted file to the web application.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the JbossMQ Invocation Layer Deserialization Remote Code Execution protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Application Servers Protection Violation.
Attack Information:  JbossMQ Invocation Layer Deserialization Remote Code Execution

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO