Check Point Advisories

Adobe Flash Player Use After Free (APSB18-03: CVE-2018-4878)

Check Point Reference: CPAI-2018-0052
Date Published: 4 Feb 2018
Severity: Critical
Last Updated: 11 Jul 2018
Source: Adobe Security Bulletin APSB18-03
Industry Reference:CVE-2018-4878
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable? Flash Player ActiveX 28.0.0.137 and earlier versions
Adobe Flash Player Desktop Runtime for Windows 28.0.0.137
Adobe Flash Player Desktop Runtime for Macintosh 28.0.0.137
Adobe Flash Player Desktop Runtime for Linux 28.0.0.137
Adobe Flash Player Google Chrome Plugin for Windows 28.0.0.137
Adobe Flash Player Google Chrome Plugin for Macintosh 28.0.0.137
Adobe Flash Player Google Chrome Plugin for Linux 28.0.0.137
Adobe Flash Player Google Chrome Plugin for ChromeOS 28.0.0.137
Adobe Flash Player Microsoft Edge and Internet Explorer 11 Plugin for Windows 10 and Windows 8.1 28.0.0.137
Vulnerability Description A remote code execution vulnerability exists in Adobe Flash Player. The vulnerability is due to a use-after-free error in Adobe Flash Player while handling a specially crafted SWF file. A remote attacker can exploit this vulnerability by enticing a target user to open a specially crafted file with an affected version of Flash Player.
Update/Patch AvaliableApply patches from: APSB18-03

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the Adobe Flash Player Use After Free (APSB18-03: CVE-2018-4878) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Adobe Flash Protection Violation.
Attack Information:  Adobe Flash Player Use After Free (APSB18-03: CVE-2018-4878)

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO