Learn more on how to stay protected from the latest Ransomware Pandemic
Check Point Advisories

Oracle WebLogic WLS Core Component Remote Code Execution (CVE-2018-2628; CVE-2018-2893)

Check Point Reference: CPAI-2018-0337
Date Published: 22 Apr 2018
Severity: Critical
Last Updated: 12 Jun 2019
Source:
Industry Reference:CVE-2018-2628
CVE-2018-2893
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? Oracle WebLogic 10.3.6.0, 12.1.3.0, 12.2.1.2 and 12.2.1.3.
Vulnerability Description A remote code execution was discovered in Oracle WebLogic. An unauthenticated attacker may use this vulnerability to execute code on the vulnerable server.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Oracle WebLogic WLS Core Component Remote Code Execution protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  Oracle WebLogic WLS Core Component Remote Code Execution

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO