Learn more on how to stay protected from the latest Ransomware Pandemic
Check Point Advisories

Git ssh URL Processing Command Execution (CVE-2017-1000117)

Check Point Reference: CPAI-2018-0364
Date Published: 2 May 2018
Severity: Low
Last Updated: 23 Jan 2019
Source:
Industry Reference:CVE-2017-1000117
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? GIT
Vulnerability Description A command execution vulnerability exists in the Git client. The vulnerability is due to insufficient validation of ssh:// URLs. Successful exploitation will enable the attacker to execute arbitrary commands on the target system.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Git ssh URL Processing Command Execution protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Client Enforcement Violation.
Attack Information:  Git ssh URL Processing Command Execution

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO