Check Point Advisories

Eclipse Jetty Denial-of-service (CVE-2018-12545)

Check Point Reference: CPAI-2018-1233
Date Published: 25 Nov 2019
Severity: Medium
Last Updated: 25 Nov 2019
Source:
Industry Reference:CVE-2018-12545
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? eclipse jetty 9.3.0 20150601
eclipse jetty 9.3.0 20150608
eclipse jetty 9.3.0 20150612
eclipse jetty 9.3.0 maintenance 0
eclipse jetty 9.3.0 maintenance 1
eclipse jetty 9.3.0 maintenance 2
eclipse jetty 9.3.0 rc0
eclipse jetty 9.3.0 rc1
eclipse jetty 9.3.1 20150714
eclipse jetty 9.3.2 20150730
Vulnerability Description A denial-of-service vulnerability exists in eclipse jetty. Successful exploitation of this vulnerability would allow a remote attacker to create a denial of service condition on the affected system.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Eclipse Jetty Denial-of-service (CVE-2018-12545) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  Eclipse Jetty Denial-of-service (CVE-2018-12545)

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO