Check Point Advisories

PhpSpreadsheet XML External Entity Injection (CVE-2018-19277)

Check Point Reference: CPAI-2019-0009
Date Published: 3 Jan 2019
Severity: High
Last Updated: 15 Jan 2019
Source:
Industry Reference:CVE-2018-19277
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable? PhpSpreadsheet up to 1.5.0
Vulnerability Description An XML external entity injection vulnerability exists in PhpSpreadsheet library. The vulnerability is due to a failure to properly handle external entity references in XML files. A successful exploitation of this vulnerability could result in the disclosure of file contents from the target system.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the PhpSpreadsheet XML External Entity Injection protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  PhpSpreadsheet XML External Entity Injection

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO