Check Point Advisories

WordPress WooCommerce Plugin Authentication Bypass (CVE-2018-20782)

Check Point Reference: CPAI-2019-0359
Date Published: 5 Mar 2019
Severity: High
Last Updated: 29 Jul 2019
Source:
Industry Reference:CVE-2018-20782
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? WordPress 4.9.9 + WooCommerce 3.5.1 + GloBee Payment Gateway Plugin 1.1.1
Vulnerability Description An authentication bypass exists in WordPress WooCommerce Plugin. The vulnerability is due to insufficient data verification and lack of any cryptographic authentication. A remote attacker can exploit this vulnerability by sending a specially crafted HTTP request.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the WordPress WooCommerce Plugin Authentication Bypass protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  WordPress Enforcement Protection.
Attack Information:  WordPress WooCommerce Plugin Authentication Bypass

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO