Check Point Advisories

StackStorm Web UI Remote Code Execution (CVE-2019-9580)

Check Point Reference: CPAI-2019-0384
Date Published: 17 Mar 2019
Severity: Critical
Last Updated: 19 Mar 2019
Source:
Industry Reference:CVE-2019-9580
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? StackStorm 2.9.2 and older
StackStorm 2.10.2 and older
Vulnerability Description A remote code execution vulnerability exists in StackStorm Web UI. Successful exploitation could lead to arbitrary code execution.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the StackStorm Web UI Remote Code Execution (CVE-2019-9580) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  StackStorm Web UI Remote Code Execution (CVE-2019-9580)

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO