Check Point Advisories

Apache Flex AMF BlazeDS Java Object Deserialization Remote Code Execution (CVE-2017-5641)

Check Point Reference: CPAI-2019-0387
Date Published: 17 Mar 2019
Severity: High
Last Updated: 3 Apr 2019
Source:
Industry Reference:CVE-2017-5641
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? Apache Flex BlazeDS (4.7.2 and earlier)
Vulnerability Description A remote code execution vulnerability exists in Apache Flex BlazeDS. This vulnerability is due to deserialization of untrusted data. A remote unauthenticated attacker may exploit this vulnerability by sending a crafted file to the target system.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Apache Flex AMF BlazeDS Java Object Deserialization Remote Code Execution (CVE-2017-5641) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Application Servers Protection Violation.
Attack Information:  Apache Flex AMF BlazeDS Java Object Deserialization Remote Code Execution (CVE-2017-5641)

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO