Check Point Advisories

Microsoft SharePoint Remote Code Execution (CVE-2019-1257)

Check Point Reference: CPAI-2019-1123
Date Published: 10 Sep 2019
Severity: Critical
Last Updated: 10 Sep 2019
Source: Microsoft CVE-2019-1257
Industry Reference:CVE-2019-1257
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable? Microsoft SharePoint Foundation 2010 Service Pack 2
Microsoft SharePoint Enterprise Server 2016
Microsoft SharePoint Server 2019
Vulnerability Description A remote code execution vulnerability exists in Microsoft Microsoft SharePoint. Successful exploitation of this vulnerability could allow a remote attacker to execute arbitrary code on the affected system.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the Microsoft SharePoint Remote Code Execution (CVE-2019-1257) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Content Protection Violation.
Attack Information:  Microsoft SharePoint Remote Code Execution (CVE-2019-1257)

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO