Check Point Advisories

MediaWiki Reflected Cross-Site Scripting (CVE-2017-8809)

Check Point Reference: CPAI-2017-1039
Date Published: 29 Jan 2020
Severity: Critical
Last Updated: 29 Jan 2020
Source:
Industry Reference:CVE-2017-8809
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? MediaWiki prior to 1.27.4
MediaWiki 1.28.x-1.28.3
MediaWiki 1.29.x-1.29.2
Vulnerability Description A reflected cross-site scripting vulnerability exists in MediaWiki. The vulnerability is due to insufficient input validation on user input in the api.php component. A remote user can exploit this vulnerability by enticing a user to click on a malicious link.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the MediaWiki Reflected Cross-Site Scripting (CVE-2017-8809) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  MediaWiki Reflected Cross-Site Scripting (CVE-2017-8809)

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO