Check Point Advisories

LAquis SCADA LGX Out-Of-Bounds Write (CVE-2018-18986)

Check Point Reference: CPAI-2018-1224
Date Published: 1 Jan 2020
Severity: High
Last Updated: 1 Jan 2020
Source:
Industry Reference:CVE-2018-18986
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? LAquis SCADA prior to 4.1.0.4150
Vulnerability Description An out-of-bounds write vulnerability exists in the LAquis SCADA. This vulnerability is due to improper validation of user-supplied data when parsing the LGX report file. Successful exploitation would result in a denial of service condition.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the LAquis SCADA LGX Out-Of-Bounds Write (CVE-2018-18986) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Content Protection Violation.
Attack Information:  LAquis SCADA LGX Out-Of-Bounds Write (CVE-2018-18986)

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO