Check Point Advisories

PostgreSQL Database Password Change Stack Buffer Overflow (CVE-2019-10164)

Check Point Reference: CPAI-2019-0976
Date Published: 13 Feb 2020
Severity: High
Last Updated: 18 Feb 2020
Source:
Industry Reference:CVE-2019-10164
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? PostgreSQL 9.4.x prior to 9.4.23
PostgreSQL 9.5.x prior to 9.5.18
PostgreSQL 9.6.x prior to 9.6.14
PostgreSQL 10.x prior to 10.9
PostgreSQL 11.x prior to 11.4
Vulnerability Description A stack buffer overflow exists in PostgreSQL Database. The vulnerability is due to a stack buffer overflow when setting a password. A remote, authenticated attacker could send a crafted request in order to trigger the vulnerability. Successful exploitation will result in arbitrary code execution.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the PostgreSQL Database Password Change Stack Buffer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Application Servers Protection Violation.
Attack Information:  PostgreSQL Database Password Change Stack Buffer Overflow

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO