Check Point Advisories

Atlassian Confluence Server Information Disclosure (CVE-2019-3394)

Check Point Reference: CPAI-2019-1693
Date Published: 23 Feb 2020
Severity: Medium
Last Updated: 23 Feb 2020
Source:
Industry Reference:CVE-2019-3394
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? Atlassian Confluence Server prior to 6.13.7
Atlassian Confluence Server prior to 6.15.8
Atlassian Confluence Server prior to 6.6.16
Vulnerability Description A local file inclusion vulnerability exists in Atlassian Confluence Server. This vulnerability is due to improper validation of file path. A remote, authenticated attacker could exploit this vulnerability by sending a crafted request to the target server. Successful exploitation could lead to information disclosure.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Atlassian Confluence Server Information Disclosure (CVE-2019-3394) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  Atlassian Confluence Server Information Disclosure (CVE-2019-3394)

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO