Learn more on how to stay protected from the latest Ransomware Pandemic
Check Point Advisories

cURL and libcurl TFTP Heap Buffer Overflow (CVE-2019-5436)

Check Point Reference: CPAI-2019-1724
Date Published: 25 Feb 2020
Severity: Medium
Last Updated: 25 Feb 2020
Source:
Industry Reference:CVE-2019-5436
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? cURL Project cURL 7.19.4 through 7.64.1
cURL Project libcURL 7.19.4 through 7.64.1
Vulnerability Description A heap-based buffer overflow vulnerability exists in cURL and libcurl. Successful exploitation of this vulnerability could result in the execution of arbitrary code in the security context of the target user.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the cURL and libcurl TFTP Heap Buffer Overflow (CVE-2019-5436) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Client Enforcement Violation.
Attack Information:  cURL and libcurl TFTP Heap Buffer Overflow (CVE-2019-5436)

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO