Learn more on how to stay protected from the latest Ransomware Pandemic
Check Point Advisories

VMWare OpenSLP Heap Buffer Overflow (CVE-2019-5544)

Check Point Reference: CPAI-2019-1794
Date Published: 26 Feb 2020
Severity: Critical
Last Updated: 26 Feb 2020
Source:
Industry Reference:CVE-2019-5544
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? VMWare ESXi 6.0 prior to ESXi600-201912001
VMWare ESXi 6.5 prior to ESXi650-201912001
VMWare ESXi 6.7 prior to ESXi670-201912001
VMWare Horizon DaaS 8.x
Vulnerability Description A heap buffer overflow vulnerability exists in OpenSLP. The vulnerability is due to improperly checking the bounds of a buffer before copying data to it. A remote, unauthenticated attacker can exploit this vulnerability by sending a specially crafted request to OpenSLP service on port 427. Successful exploitation could result in arbitrary code execution in the context of the target server.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the VMWare OpenSLP Heap Buffer Overflow (CVE-2019-5544) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  VMWare OpenSLP Heap Buffer Overflow (CVE-2019-5544)

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO