Check Point Advisories

NGINX NJS Heap-Based Buffer Overflow (CVE-2019-11838)

Check Point Reference: CPAI-2019-2069
Date Published: 17 May 2020
Severity: High
Last Updated: 17 May 2020
Source:
Industry Reference:CVE-2019-11838
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? NGINX NJS prior to 0.3.1
Vulnerability Description A buffer overflow vulnerability exists in NGINX NJS. Successful exploitation of this vulnerability could allow a remote attacker to execute arbitrary code on the affected system or cause application crashes.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the NGINX NJS Heap-Based Buffer Overflow (CVE-2019-11838) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  NGINX NJS Heap-Based Buffer Overflow (CVE-2019-11838)

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO