Check Point Advisories

Adobe Flash Player Type Confusion (APSB20-06: CVE-2020-3757)

Check Point Reference: CPAI-2020-0068
Date Published: 11 Feb 2020
Severity: Critical
Last Updated: 11 Feb 2020
Source: Adobe APSB20-06
Industry Reference:CVE-2020-3757
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? Adobe Flash Player Microsoft Edge and Internet Explorer 11 Plugin for Windows 10 and Windows 8.1 32.0.0.322,Adobe Flash Player Google Chrome Plugin for ChromeOS 32.0.0.322,Adobe Flash Player Google Chrome Plugin for Linux 32.0.0.322,Adobe Flash Player Google Chrome Plugin for Macintosh 32.0.0.322,Adobe Flash Player Google Chrome Plugin for Windows 32.0.0.322,Adobe Flash Player Desktop Runtime for Linux 32.0.0.322,Adobe Flash Player Desktop Runtime for Macintosh 32.0.0.322,Adobe Flash Player Desktop Runtime for Windows 32.0.0.322
Vulnerability Description A type confusion vulnerability exists in Adobe Flash Player. Successful exploitation of this vulnerability could allow a remote attacker to execute arbitrary code on the affected system.
Update/Patch AvaliableApply patches from: APSB20-06

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Adobe Flash Player Type Confusion (APSB20-06: CVE-2020-3757) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Adobe Flash Protection Violation.
Attack Information:  Adobe Flash Player Type Confusion (APSB20-06: CVE-2020-3757)

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO