Learn more on how to stay protected from the latest Ransomware Pandemic
Check Point Advisories

WordPress Canto Plugin Server-Side Request Forgery (CVE-2020-28976; CVE-2020-28977; CVE-2020-28978)

Check Point Reference: CPAI-2020-1287
Date Published: 27 Dec 2020
Severity: Medium
Last Updated: 27 Dec 2020
Source:
Industry Reference:CVE-2020-28976
CVE-2020-28977
CVE-2020-28978
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? WordPress Canto Plugin 1.3.0
Vulnerability Description A sever-side request forgery vulnerability exists in WordPress Canto Plugin. The vulnerability is due to a lack of validation on the subdomain parameter in HTTP requests. Successful exploitation of this vulnerability could allow an unauthenticated attacker to make a request to any internal and external server.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the WordPress Canto Plugin Server-Side Request Forgery (CVE-2020-28976) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  WordPress Enforcement Protection.
Attack Information:  WordPress Canto Plugin Server-Side Request Forgery (CVE-2020-28976)

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO