Check Point Reference:CPAI-2012-640
Date Published: 21 Oct 2012
Severity: High
Last Updated:
Source: CVE-2012-4165
Protection Provided by:

Security Gateway
R70

  • R71
  • R75

  • Who is Vulnerable? Adobe Flash Player 11.3.300.271 and earlier versions for Windows and Macintosh operating systems
    Adobe Flash Player 11.2.202.236 and earlier versions for Linux operating system
    Adobe Flash Player 11.1.115.11 and earlier versions for Android 4.x
    Adobe Flash Player 11.1.111.10 and earlier versions for Android 3.x and 2.x
    Adobe AIR 3.3.0.3670 and earlier versions for Windows and Macintosh
    Adobe AIR 3.3.0.3690 SDK (includes AIR for iOS) and earlier versions
    Adobe AIR 3.3.0.3650 and earlier versions for Android
    Vulnerability Description A remote code execution vulnerability has been reported in Adobe Flash Player.
    Update/Patch AvaliableApply patches from: APSB12-19
    Vulnerability DetailsThe vulnerability is due to memory corruption in Flash Player while handling malformed .swf files. A remote attacker can exploit this vulnerability by enticing a target user to open a specially crafted SWF file with an affected version of the application. Successful exploitation would allow an attacker to execute arbitrary code.

    Protection Overview

    This protection will detect and block attempts to exploit this vulnerability.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Adobe Flash Player Malformed Byte Code Remote Code Execution (APSB12-19) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:
    Attack Name: Adobe Products Violation
    Attack Information: Adobe Flash Player Malformed Byte Code Remote Code Execution (APSB12-19)