Check Point Reference:CPAI-2013-1267
Date Published: 12 Feb 2013
Severity: Critical
Last Updated:
Source: CVE-2013-0019
Protection Provided by:

Security Gateway
R70

  • R71
  • R75

  • Who is Vulnerable? Internet Explorer 6 for Windows XP Service Pack 3
    Internet Explorer 6 for Windows XP Professional x64 Edition Service Pack 2
    Internet Explorer 6 for Windows Server 2003 Service Pack 2
    Internet Explorer 6 for Windows Server 2003 x64 Edition Service Pack 2
    Internet Explorer 6 for Windows Server 2003 with SP2 for Itanium-based Systems
    Internet Explorer 7
    Internet Explorer 7 for Windows XP Service Pack 3
    Internet Explorer 7 for Windows XP Professional x64 Edition Service Pack 2
    Internet Explorer 7 for Windows Server 2003 Service Pack 2
    Internet Explorer 7 for Windows Server 2003 x64 Edition Service Pack 2
    Internet Explorer 7 for Windows Server 2003 with SP2 for Itanium-based Systems
    Internet Explorer 7 in Windows Vista Service Pack 2
    Internet Explorer 7 in Windows Vista x64 Edition Service Pack 2
    Internet Explorer 7 in Windows Server 2008 for 32-bit Systems Service Pack 2
    Internet Explorer 7 in Windows Server 2008 for x64-based Systems Service Pack 2
    Internet Explorer 7 Windows Server 2008 for Itanium-based Systems Service Pack 2
    Internet Explorer 8
    Internet Explorer 8 for Windows XP Service Pack 3
    Internet Explorer 8 for Windows XP Professional x64 Edition Service Pack 2
    Internet Explorer 8 for Windows Server 2003 Service Pack 2
    Internet Explorer 8 for Windows Server 2003 x64 Edition Service Pack 2
    Internet Explorer 8 in Windows Vista Service Pack 2
    Internet Explorer 8 in Windows Vista x64 Edition Service Pack 2
    Internet Explorer 8 in Windows Server 2008 for 32-bit Systems Service Pack 2
    Internet Explorer 8 in Windows Server 2008 for x64-based Systems Service Pack 2
    Internet Explorer 8 in Windows 7 for 32-bit Systems
    Internet Explorer 8 in Windows 7 for 32-bit Systems Service Pack 1
    Internet Explorer 8 in Windows 7 for x64-based Systems
    Internet Explorer 8 in Windows 7 for x64-based Systems Service Pack 1
    Internet Explorer 8 in Windows Server 2008 R2 for x64-based Systems
    Internet Explorer 8 in Windows Server 2008 R2 for x64-based Systems Service Pack 1
    Internet Explorer 8 in Windows Server 2008 R2 for Itanium-based Systems
    Internet Explorer 8 in Windows Server 2008 R2 for Itanium-based Systems Service Pack 1
    Internet Explorer 9
    Internet Explorer 9 for Windows Vista Service Pack 2
    Internet Explorer 9 for Windows Vista x64 Edition Service Pack 2
    Internet Explorer 9 for Windows Server 2008 for 32-bit Systems Service Pack 2
    Internet Explorer 9 for Windows Server 2008 for x64-based Systems Service Pack 2
    Internet Explorer 9 for Windows 7 for 32-bit Systems
    Internet Explorer 9 for Windows 7 for 32-bit Systems Service Pack 1
    Internet Explorer 9 for Windows 7 for x64-based Systems
    Internet Explorer 9 for Windows 7 for x64-based Systems Service Pack 1
    Internet Explorer 7 for Windows XP Service Pack 3
    Internet Explorer 7 for Windows XP Professional x64 Edition Service Pack 2
    Internet Explorer 7 for Windows Server 2003 Service Pack 2
    Internet Explorer 7 for Windows Server 2003 x64 Edition Service Pack 2
    Internet Explorer 7 for Windows Server 2003 with SP2 for Itanium-based Systems
    Internet Explorer 7 in Windows Vista Service Pack 2
    Internet Explorer 7 in Windows Vista x64 Edition Service Pack 2
    Internet Explorer 7 in Windows Server 2008 for 32-bit Systems Service Pack 2
    Internet Explorer 7 in Windows Server 2008 for x64-based Systems Service Pack 2
    Internet Explorer 7 Windows Server 2008 for Itanium-based Systems Service Pack 2
    Internet Explorer 8
    Internet Explorer 8 for Windows XP Service Pack 3
    Internet Explorer 8 for Windows XP Professional x64 Edition Service Pack 2
    Internet Explorer 8 for Windows
    Vulnerability Description A remote code execution vulnerability has been reported in Microsoft Internet Explorer.
    Update/Patch AvaliableApply patches from: MS13-009
    Vulnerability DetailsThe vulnerability is due to an error in the way Internet Explorer accesses an object in memory that has been deleted. A remote attacker can exploit this issue by enticing a target victim to open a specially crafted web page. Successful exploitation could cause memory corruption in a way that would allow attackers to execute code on the target.

    Protection Overview

    This protection will detect and block attempts to open a malicious HTML file.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Internet Explorer COmWindowProxy Use After Free (MS13-009) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:
    Attack Name: Web Client Enforcement Violation
    Attack Information: Internet Explorer COmWindowProxy Use After Free (MS13-009)