Check Point Reference:CPAI-2014-0954
Date Published: 18 Mar 2014
Severity: Critical
Last Updated:18 Mar 2014
Source: CVE-2014-0491
Protection Provided by:

Security Gateway
R70

  • R71
  • R75 and above

  • Who is Vulnerable? Adobe Flash Player 11.9.900.170 and earlier versions for Windows and Macintosh
    Adobe Flash Player 11.2.202.332 and earlier versions for Linux
    Adobe AIR 3.9.0.1380 and earlier versions for Windows and Macintosh
    Adobe AIR 3.9.0.1380 and earlier versions for Android
    Adobe AIR 3.9.0.1380 SDK and earlier versions
    Adobe AIR 3.9.0.1380 SDK & Compiler and earlier versions
    Vulnerability Description A cross-site scripting vulnerability has been reported in Adobe Flash Player. The vulnerability is due to an error in the way the browser and the plug-in handle specially crafted URLs. A remote attacker can exploit this vulnerability by enticing an affected user to open a malicious web-page.
    Update/Patch AvaliableApply patches from: APSB14-02

    Protection Overview

    This protection will detect and block the transferring of malformed SWF files over HTTP.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Adobe Flash Player Cross-Site Scripting (APSB14-02: CVE-2014-0491) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:

    Attack Name:  Adobe Flash Protection Violation.
    Attack Information:  Adobe Flash Player Cross-Site Scripting (APSB14-02: CVE-2014-0491)