Check Point Reference:CPAI-2014-1546
Date Published: 18 May 2014
Severity: High
Last Updated:18 May 2014
Source:
Protection Provided by:

Security Gateway
R77

  • R76
  • R75

  • Who is Vulnerable? Vtiger 6.0.0 or older
    Vulnerability Description A command execution vulnerability has been reported in Vtiger CRM. The vulnerability is due to an arbitrary command execution in install script. A remote attacker may exploit this vulnerability by overwriting the target database configuration.

    Protection Overview

    This protection will detect and block an arbitrary command execution in Vtiger CRM install script.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Vtiger CRM Install Script Remote Command Execution protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:

    Attack Name:  Content Protection Violation.
    Attack Information:  Vtiger CRM Install Script Remote Command Execution