Check Point Reference:CPAI-2014-0931
Date Published: 23 Feb 2014
Severity: High
Last Updated:
Source: CVE-2014-0502
Protection Provided by:

Security Gateway
R75 and above

  • R71
  • R70

  • Who is Vulnerable? Flash Player 12.0.0.44 and earlier versions for Windows and Macintosh
    Flash Player 11.2.202.336 and earlier for Linux
    Flash Player 12.0.0.44 and earlier for Chrome (Windows, Macintosh and Linux)
    Flash Player 12.0.0.44 and earlier in Internet Explorer 10 for Windows 8.0
    Flash Player 12.0.0.44 and earlier in Internet Explorer 11 for Windows 8.1
    AIR 4.0.0.1390 and earlier for Android
    AIR 4.0.0.1390 SDK & Compiler
    AIR 4.0.0.1390 SDK
    Vulnerability Description A remote code execution vulnerability has been reported in Adobe Flash Player. The vulnerability is due to a double-free condition when handling specially crafted SWF files. Successful exploitation would allow an attacker to take complete control of the affected system.

    Protection Overview

    This protection will detect and block attempts to exploit this vulnerability.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Adobe Flash Player Double Free Remote Code Execution (APSB14-07; CVE-2014-0502) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:
    Attack Name: Adobe Reader Violation
    Attack Information: Adobe Flash Player Double Free Remote Code Execution (APSB14-07; CVE-2014-0502)