Check Point Advisories

HP OpenView Storage Data Protector EXEC_CMD Buffer Overflow (CVE-2011-1866)

Check Point Reference: CPAI-2011-479
Date Published: 1 Nov 2011
Severity: Critical
Last Updated: 14 Feb 2016
Source:
Industry Reference:CVE-2011-1866
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable?
Vulnerability Description A remote code execution vulnerability has been reported in HP OpenView Storage Data Protector. The vulnerability is due to insufficient boundary checking while handling EXEC_CMD messages. A remote attacker may exploit this vulnerability by sending a specially crafted EXEC_CMD to an affected service. Successful exploitation would allow an attacker to execute arbitrary code in the user's security context.

Protection Overview

This protection will detect and block the transferring of malicious EXEC_CMD packets to the server.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the HP OpenView Storage Data Protector EXEC_CMD Buffer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  HP Products Protection Violation.
Attack Information:  HP OpenView storage data protector EXEC_CMD buffer overflow

This website uses cookies to ensure you get the best experience. More Info Got it, Thanks!