Check Point Advisories

GnuTLS X.509 Version 1 Intermediate Certificate Policy Bypass (CVE-2014-1959)

Check Point Reference: CPAI-2014-1520
Date Published: 4 May 2014
Severity: High
Last Updated: 20 Nov 2017
Source: GnuTLS GNUTLS-SA-2014-1
Industry Reference:CVE-2014-1959
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable? GnuTLS 3.1.x prior to 3.1.21
GnuTLS 3.2.x prior to 3.2.11
Vulnerability Description A policy-bypass vulnerability has been found in GnuTLS. The vulnerability is due to an error in lib/x509/verify.c where an X.509 version 1 certificate is incorrectly treated as an intermediate CA certificate. A remote attacker could exploit this vulnerability to bypass certificate validation.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the GnuTLS X.509 Version 1 Intermediate Certificate Policy Bypass protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  OpenSSL Enforcement Violation.
Attack Information:  GnuTLS X.509 Version 1 Intermediate Certificate Policy Bypass

This website uses cookies to ensure you get the best experience. More Info Got it, Thanks!