How can I help you? Start Chat

US Phone: 1-866-488-6691
International Phone: +44-2036087492

  • E-Mail
  • Facebook
  • LinkedIn
  • Twitter

Check Point Advisories

Wireshark SigComp UDVM Dissector Remote Code Execution - Ver2 (CVE-2010-2287)

Check Point Reference: CPAI-2015-0388
Date Published: 26 Mar 2015
Severity: High
Last Updated: 26 Mar 2015
Source:
Industry Reference:CVE-2010-2287
Protection Provided by:

Security Gateway
R77, R76, R75

Who is Vulnerable?
Vulnerability Description A buffer overflow vulnerability has been reported in Wireshark. The vulnerability is due to incorrect implementation of the SigComp UDVM Dissector. An attacker can exploit this issue by sending a malicious sigComp traffic in the internet.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated,

update your Security Gateway product to the latest IPS update.


For information on how to update IPS, go to



SBP-2006-05
,

Protection tab and select the version of your choice.

Security Gateway R77 / R76 / R75 / R71 / R70

  1. In the IPS tab, click Protections and find the Wireshark SigComp UDVM Dissector Remote Code Execution - Ver2 protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

SmartView Tracker will log the following entries:

Attack Name:  Content Protection Violation.
Attack Information:  Wireshark SigComp UDVM Dissector Remote Code Execution - Ver2