Check Point Advisories

Microsoft JET Database Engine Excel Component Heap-based Buffer Overflow (CVE-2017-8718)

Check Point Reference: CPAI-2017-1065
Date Published: 14 Dec 2017
Severity: Critical
Last Updated: 20 Dec 2017
Source: Microsoft
Industry Reference:CVE-2017-8718
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable? Microsoft Windows 7
Microsoft Windows 8.1
Microsoft Windows 10
Microsoft Windows RT 8.1
Microsoft Windows Server 2008
Microsoft Windows Server 2012
Microsoft Windows Server 2016
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012 (Server Core)
Microsoft Windows Server 2012 R2
Microsoft Windows Server 2012 R2 (Server Core)
Microsoft Windows Server 2016 Server Core
Vulnerability Description A heap-based buffer overflow vulnerability exists in the Microsoft Jet Database Engine (Jet). The vulnerability is due to an error in the way Microsoft JET Database Engine improperly handles objects in memory while parsing specially crafted Excel files. A remote attacker can exploit this issue by enticing a victim to open a specially crafted file.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the Microsoft JET Database Engine Excel Component Heap-based Buffer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Content Protection Violation.
Attack Information:  Microsoft JET Database Engine Excel Component Heap-based Buffer Overflow

This website uses cookies to ensure you get the best experience. More Info Got it, Thanks!